System Requirements

UL PureSafety recommends the following system settings and software to successfully interact with our websites and services.

General Browser Requirements

Your browser must meet the following requirements:

  1. • The browser must be configured to accept cookies
  2. • The browser must be configured to execute JavaScript
  3. • The browser must be capable of 128-bit SSL encryption

Refer to our Browser Support Policy for a list of supported browsers.


Adobe Flash Player & Reader Requirements

Adobe Flash Player is required for viewing Training Courses and Tests on the PureSafety system. Adobe Reader is required for viewing and printing Training Materials and Diplomas. We highly recommend keeping these programs up-to-date. To see what version of Flash Player your browser is currently using, click Check My System.

Browser Support Policy


To better meet your needs, UL PureSafety uses statistical data from web visitors and registered users, rather than generic industry data, to identify the browsers used by our target audience. We regularly review this data to determine which browsers to support.


Supported Browsers

UL PureSafety validates against and supports the following browsers:

  1. Chrome (latest version)
  2. Internet Explorer (8, 9, 10, 11)
  3. Firefox (latest version)
  4. Safari (mobile only)

Other browsers might also work, but we do not attempt to resolve problems with browser/platform combinations other than those listed above. Browsers that have been developed to comply with the W3C guidelines and specifications, including mobile browsers, should operate successfully.


Resolving Browser Issues

If you are experiencing a problem using one of the browsers we support, click Check My System for assistance. If you are experiencing a problem on an unsupported browser, the issue might be resolved by moving to a supported browser.

Check My System

Below is the information for your current platform, browser and plugins. Check to make sure your system meets our System Requirements and Supported Browsers.

Browser Information
Browser Name
Browser Version
Browser Supported
Style Sheets
Java Script
Java
XML
File Upload
Cookies
Popup Blocker Check popup blocker

User Information
Platform
Proxy Server
SSL
Screen Size
Broadband Connection
Connection Speed
IP Address

Plugin Information
Adobe Flash
(Download Now)
Adobe Shockwave Director
(Download Now)
Adobe Acrobat
(Download Now)

Minimum Requirements

Requirements Minimum Recommended
Processor 1.2GHz Intel® Pentium® 1.8GHz Intel® Pentium®
RAM 256 MB 1 GB
Internet Connection 256 Kbps 10 Mbps
Sound/Speakers 16-bit 16-bit
Video/Display 65,000 Color 65,000 Color
Operating System Windows Vista, Windows 7, Windows 8.1, iOS 7.1.1 Windows Vista, Windows 7, Windows 8.1, iOS 7.1.1
Browser IE 8, 9, 10 and 11;
FireFox 19.0.2; Chrome 26.0.1410.43
IE 8, 9, 10 and 11; FireFox 19.0.2; Chrome 26.0.1410.43

Need Assistance?

If you are still experiencing problems after checking that your system meets our requirement, complete the form below to get assistance from our Product Support Team.